Skip to main content

Java Loops | HackerRank solutions -codewithyasar

  Objective In this challenge, we're going to use loops to help us do some simple math. Task Given an integer,  , print its first   multiples. Each multiple   (where  ) should be printed on a new line in the form:  N x i = result . Input Format A single integer,  . Constraints Output Format Print   lines of output; each line   (where  ) contains the   of   in the form: N x i = result . Sample Input 2 Sample Output 2 x 1 = 2 2 x 2 = 4 2 x 3 = 6 2 x 4 = 8 2 x 5 = 10 2 x 6 = 12 2 x 7 = 14 2 x 8 = 16 2 x 9 = 18 2 x 10 = 20 Explanation:           Here, we just need to use for loops to achieve the result Solution : import java.io.* ; import java.math.* ; import java.security.* ; import java.text.* ; import java.util.* ; import java.util.concurrent.* ; import java.util.regex.* ; public class Solution { public static void main ( String [] args ) throws IOException { BufferedReader bufferedReader = new BufferedReader ( new InputStreamReader ( Syste

Balanced Paranthesis

 Problem Statement:

      Program to check for balanced parentheses in an expression using stack.
      Given an expression as string comprising of opening and closing characters
      of parentheses - (), curly braces - {} and square brackets - [], we need to 
      check whether symbols are balanced or not. 


Approach:

        Using Stack, We are going to solve this Problem

 
Solution:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
//Java program for Balanced Paranthesis
import java.util.*;
import java.io.*;
public class MyClass {
    public static void printStack(Stack<Character> s)
    {
        if(s.empty())
        {
            return;
        }
        
        Character x=s.peek();
        System.out.println(x);
        s.pop();
        printStack(s);
    }
    public static boolean arePair(char opening,char closing)
    {
        if(opening=='(' && closing==')')
            return true;
        else if(opening=='[' && closing==']')
           return true;
        else if(opening=='{' && closing=='}')
            return true;
        return false;
    }
    public static void main(String args[]) 
    {
     String input="[(])";
     Stack<Character> stack = new Stack<Character>();
     for(int i=0; i<input.length();i++) 
     {
        //  System.out.println(input.charAt(i));
        
        if(input.charAt(i)=='(' | input.charAt(i)=='{' | input.charAt(i)=='[')
        {
            stack.push(input.charAt(i));
        }
        else if(input.charAt(i)==')' | input.charAt(i)=='}' | input.charAt(i)==']')  
        {
            if(stack.empty() |  !arePair(stack.peek(),input.charAt(i))) 
            {
                System.out.println("Cannot balanced unpaired Pair Found!!");
                return;
            }
            else 
                stack.pop();
        }
     }
        if(stack.empty()) {
         System.out.println("Balanced Paranthesis");
         } else {
             System.out.println("UnBalanced");
         }
    }
     
    //  printStack(stack);
    
    
}
Feel free to Bookmark this site.Happy Coding

Comments

Highlights

Super ASCII String Checker | CodeVita | PYTHON CODE

Problem: In the Byteland country a string "S" is said to super ascii string if and only if count of each character in the string is equal to its ascii value. In the Byteland country ascii code of 'a' is 1, 'b' is 2 ...'z' is 26. Your task is to find out whether the given string is a super ascii string or not. Input Format: First line contains number of test cases T, followed by T lines, each containing a string "S". Output Format: For each test case print "Yes" if the String "S" is super ascii, else print "No" Constraints: 1<=T<=100 1<=|S|<=400, S will contains only lower case alphabets ('a'-'z'). Explanation: For eg1 - String "bba" is super ascii string Explanation:- .String "bba" The count of character 'b' is 2. Ascii value of 'b' is also 2. The count of character 'a' is 1. Ascii value of 'a' is also 1. Hence string "bba"

Lexi String | codevita |Python Solution

Lexi String Little Jill jumbled up the order of the letters in our dictionary. Now, Jack uses this list to find the smallest lexicographical string that can be made out of this new order. Can you help him? You are given a string P that denotes the new order of letters in the English dictionary. You need to print the smallest lexicographic string made from the given string S. Constraints: 1 <= T <= 1000 Length (P) = 261 <= length (S) <= 100 All characters in the string S, P are in lowercase Input Format The first line contains number of test cases T The second line has the string P The third line has the string S Output Print a single string in a new line for every test case giving the result Test Case Example 1 Input 2 polikujmnhytgbvfredcxswqaz abcd qwryupcsfoghjkldezxvbintma ativedoc Output bdca codevita Explanation: The transformed smallest lexicographical strings are in order they would be if order of letters are changed to string P

Haunted Hotel

Haunted Hotel Follow the instructions to live 6th June 1906, there was a big fire accident at a 5 star hotel in which more than 160 people died, from that time no one even dared to go near that burnt place, because it was believed that the place became haunted. This fear among people went increasing due to the suspicious deaths of the people who tried entering the hotel. More than 100 years have passed, but that has not reduced thee fear among the people even a bit. Dhoni is a person who likes adventures, so wanted to see what actually is the mystery of the hotel. So on a Friday evening he went inside the hotel with a camera which was live streamed live on his Facebook page.   The live stream lasted not even for an hour, all the electronic equipment he had began malfunctioning. He might be brave, but being alone in a place which is believed to be haunted and that too in late evening, his nerves got him. It was so quite so that, he could hear his own heart beat increasing as a drum